2021年10月27日(水) 09:08 JST

Android SDK 2.0でハマる

  • 2009年11月 8日(日) 00:58 JST
  • 投稿者:
    nonoz

1.6→2.0へのアップグレードは eclipse上でできる、みたいな記事を読んでやってみてから、ハマってしまいました。たしかにeclipse上でアップグレードできた(みたいにみえた)のですが、次に使おうとeclipseを起動すると、ADTがメニュー上から消えてなくなってました。

しょうがないので、もういちどインストールしようとすると、「もう入っているよ!」という意味のメッセージがでてインストールさせてくれません。ちょうどubuntuも 9.10が出たところなので、ubuntu 9.10へアップグレードした後に再挑戦しました。



とりあえず、eclipseのインストールからやり直しだな。

前はubuntuのパッケージに入っているeclipseのバージョンが低かったので、 自前でインストールしたんだっけ。

今回は、ubuntu 9.10にも、eclipse 3.5(ガリレオ)パッケージが入っているので、 これを使うことにします。パッケージマネージャーで、eclipse-rcpを選んでインストール。 おや? eclipseがメニューに現れない。おお、eclipse-platformを選ばないといけないのか。 それもインストールすると、無事eclipseがGNOMEのメニューに出現。

eclipseを立ち上げて、ADTをインストール。あれ???? org.eclipse.wst.xmlなんちゃらが足りないとか言っているぞ。これなんだ?? まだパッケージが足りないのかー とばかし他のeclipseパッケージを追加してみる。 (たぶん、これ間違いですね)

でもやっぱり ADTをインストールしようとすると、org.eclipse.wst.xmlなんちゃらが足りんと言われてしまう。

Google先生に相談してみると、どうやらWSTプラグインがインストールされてないようです。他にも、EMFとかGEFプラグインがインストールされていないようです。あれぇぇ?このまえ自前インストールしたとき、こんなの自分で入れたっけ?? 前はwww.eclipse.orgのRCP/plug-in版をインストールしたんですが、これにはあらかじめWSTとか含まれているんでしょうかね? しょうがないのであれこれ自分でインストールしてまわりました。ADTが無事にインストールできるまで、かれこれ 3時間以上かかってしまいました。

トラックバック

このエントリのトラックバックURL:
http://nzlab.nztype.net/trackback.php?id=20091108005841722
表示形式
コメント投稿

コメントは投稿者の責任においてなされるものであり、サイト管理者は責任を負いません。